Home / PC Gaming / Hardware / Store / Discord

Uninstalled GPU Driver, Blank Screen Now


#1

Hello, I just uninstalled my GPU driver so I could restart my PC and install the new driver however, all I get is a blank screen. I mean I cannot even get into the BIOS. What the hell happened? My specs are,

ASUS Sabertooth 990FX R2.0
AMD FX 8350
Corsair Vengeance 16GB DDR 3 RAM
WD Black 1 TB HDD
Sapphire Vapor-X R9 280X
Thermaltake Smart M750W PSU
Windows 7 Home Premium 64-Bit


#2

Did you reset the BIOS? If not try that first.


#3

yeah, something else went funky if you can’t get into the UEFI/bios… Reset the bios and let us know.


#4

The FX series chips do not ship with onboard graphics, so you will need your graphics card connected to your monitor to be able to get into the UEFI.


#5

Ok so I was finally able to get into the BIOS and then was able to get into windows and installed the new GPU driver. After restarting a couple times I am now back at a blank screen unable to do anything again. This is perplexing. I unplugged everything and plugged it back in to make sure all the cables were tight and even tried new power cables for everything and still nothing.
I took out my HDD to see if I could get back into the BIOS and nothing. What could possibly be wrong? Bad motherboard? GPU? This is maddening. The thing that is weird is I don’t even know how I was able to get back into the BIOS seeing how I got an image on my monitor seemingly randomly. :frowning:


#6

Have you tried one stick of RAM at a time? also do you have any other GPUs around?


#7

I never hared of GPU drivers uninstall causing anything to do with BIOS. I think what could of happened (which happened to me) is your GPU is sagging. Try to make sure your GPU is not hanging hard on the PCIe port. Maybe prop it up with some Lego?


#8

I have tried one stick of RAM at a time and no go. My GPU does sag. I will fiddle with it when I get off work. Do you think the GPU sagging could have damaged my motherboard?


#9

Do you see the system POST on the screen consistently? If so I’m willing to bet it’s not a hardware issue but rather a software issue.

One thing you can try is booting a Linux Live CD and see if you get a display that way.


#10

I can’t see the screen so I do not know if it is posting or not. This motherboard did not come with a speaker so if it is trying to beep I have no clue. I fear the worst :frowning:


#11

Alright, know anyone with a spare GPU you can test with? I’ve had a few GPUs just outright die.


#12

Sadly no :frowning:


#13

Can you try a different connector on the GPU? Maybe that connector has gone bad.


#14

I tried the other DVI connector as well as the HDMI port and nothing :frowning:


#15

Yeah with what you’re telling us I’m sorry pal but it sounds like either bad GPU or something wrong with the Motherboard.


#16

If it is GPU sag, there is slight chance the motherboard got damaged and that specific PCIe slot may no longer work. If your motherboard has another PCIe slot that you can put the GPU in, you could try that. Other then that i dont know, it could be dead gpu or motherboard.


#17

That motherboard is on the older side. I have had funny things happen with some 990FX chipsets when the CMOS batt dies. Maybe try pulling the battery and put a new one it. I know strange but worth a shot


#18

Try a different power supply if you have one.

Assuming your chip isn’t overclocked, you’re using at least 500w under max load. I would put a 1000W PSU in it if that one burned out.


#19

I’m going to try a new battery and then try my uncle’s gpu and if none of that works then I am stumped


#20

Ok this is weird. Sometimes it will post and boot into windows and sometimes it doesn’t do anything and I notice when that happens the boot device led doesn’t light up. So sometimes it sees my HDD and sometimes it doesn’t. What is happening?