Home / PC Gaming / Hardware / Store / Discord

System not starting - Motherboard lights up


#1

Hello everyone. Got a rather sneaky issue here.

I just built my first custom loop watercooled PC.
Problem is: Pressing the power button does absolutely nothing. No fans spinning up, no pump pumping, no POST, nothing. Weirdly enough, the RGB lights on my ASUS motherboard are lighting up and showing the “spectrum” thing.
Here’s my specs:
AMD Ryzen 7 1700; ASUS Prime X370-Pro; Gainward GTX 1080 GLH; 2x8GB Corsair Vengeance LPX DDR4-3000; Corsair RM1000x PSU + BitFenix Alchemy 2.0 cables. Water cooling parts are from EKWB.

I have tested the entire system on air, even the BitFenix cables prior to installation in the case, it worked fine outside the case and without water blocks. I also made sure to install all the plastic isolating washers where needed.

Here’s what I’ve tried so far:

  • Replacing BitFenix cables with standard Corsair cables that came with the PSU

  • Unplugged all devices from PSU except 24pin+CPU power

  • Cleared CMOS

What I was thinking is maybe a screw or something between the mobo and mobo tray shorting it out? But wouldn’t the lights on the motherboard remain off then? What else could cause the problem?

pls help. I really don’t want to pull apart my entire loop (again), I have about a quarter gallon worth of EK Pastel liquid in the system. :frowning:


#2

Check you didn’t get it wet.


#3

You could try re-routing the reset switch to the power switch, and using the reset button to power the PC up. They are both identical. Worth checking before taking the system apart.


#4

Thanks for the reply.
I didn’t. Haha


#5

I have tried just shorting the power pins with a screwdriver (same effect as a button being pressed down). Still nothing.


#6

Hold the power button down and push on your CPU block hard enough you can feel it start to flex.

I have consistently been finding mounting pressure issues using EK’s blocks. Usually on other boards though.