Home / PC Gaming / Hardware / Store / Discord

My wifi keeps cutting out


#1

So my USB wifi thingy keeps cutting off mid game and it’s making me furious. I’ve had to unplug it and plug it back in over and over. All my drivers are up to date. The only thing that has changed in my system is my graphics card which shouldn’t matter. The wifi adapter is the Netgear A6210. It pairs well with my router. My router is fairly new (about a year) and it is on the expensive side. I’ve tried different ports and unplugging things but it is no use.
Imagine you are in 1st place in a race in GTA and all of sudden it sends you back to Franklin. It makes me sweat. This also has a weird effect while I was playing Borderlands the pre sequel. (Yes, it is poorly optimized) I was playing it solo and the sound cuts out all together when the network adapter fails.
On a somewhat related note, my system blue screens on start up a few times before actually working. Any suggestions are appreciated. My budget for this fix is $0.00


#2

When using the USB adapter on other devices, does it disconnect then?

Have you tried using a different USB port to plug in? (I know you said you tried different ports, but like did you just switch to another front panel one or you using the main/back as well?)

Does any other devices on your network cut out? Or do you know if it is for sure the adapter?

Have you contacted Netgear? Have you tried swapping units?


#3

If the USB device is getting really warm temperature-wise it will switch-off or cause other problems.


#4

Before I had this adapter, I had a Wifi card that was PCIe and it was the same deal after a while. I had to unplug it and plug it back in. I’ve tried all ports. I don’t have any other computers to try it on unfortunately. I have not contacted Netgear because I don’t have the box it came in but I’ll give it a shot now.
(Also) My phone does fine, it never disconnects from wifi.


#5

if a different wifi card did the same it’s the router. send it to warranty to get it fixed… if it’s affecting other devices too like yer phone or laptop


#6

This issue is mostly resolved. I unplugged a few things like the front panel USB. I also defucked the adapter. It was set to turn off in order to save power. There are still other issues but hopefully those will be resolved as well.