Home / PC Gaming / Hardware / Store / Discord

Journey Into OpenIndiana - Revisited [Still Can't Play P0rn- Still Not CLICKBAIT ]


#1

So while ago on the old Tek Syndicate Forums i wrote this guide (Below the Revisit ) into installing and the doing maintenance on this OpenIndiana

I Have Revisited the machine over the weekend, while i was doing Fedora upgrades i thought i might play around and upgrade this machine to see what has changed. Not Much as i have found out.

There were a lot off hardware support issues that i forgot about AKA the audio. Also won’t boot on first turn on. this maybe due the the expanding CAPs on the board.

Having a Dual core that only Ran a 1.8Ghz and 2 GB or ram. Lets just say the update only took about 4 hours, and was swapping out to disk. this differently need a Hardware upgrade. Might upgrade to one of quad core 771 Xeons OC in 775 board.

Was looking at how to make this a VNC server and VNC over to it, for the other project that i am embarking on. but all and all not still works well in web browsing.

    _______________________________Original Guide _________________________________

Openindiana is a os built on the illumos based OS this was forked from the OpenSolaris, when Oracle Brought Sun and stopped opensourcing parts of Solaris.

Anyway lets begin.
The Hardware.

IBM/LENOVO USFF PC ( with a few Blown Caps but was $3.50)

  • 160 GB HDD
  • Core2Duo 1.8Ghz
  • 2 GB Ram

We begin By Downloading Hipster Branch of OpenIndiana Found Here

I first tried the DVD image http://dlc.openindiana.org/isos/hipster/latest//OI-hipster-gui-20161030.iso

Then then proceeded to DD the image, to a 8GB Flash drive( 32GB in this case)

On Fedora i did this

Listed the Drives
“Sudo fdisk -l”

Un-mounted the Drive
umount /dev/sdc
umount /dev/sdc1
umount /dev/sdc2
umount /dev/sdc3
08379a0dd6dc500d412ef906dbe4c51800ba225d

Then DD the Image
cd Downloads
sudo dd bs=4M if=OI-hipster-gui-20161030.iso of=/dev/sdc
ee3c5bb58fc0e9ac64c2597b8a61e5a7bb1b0d35

So i plug the flash drive in and for the computer to boot and Nothing.
and i try again, nothing. Hummmm me thinks.
Maybe download the image again?
I look at the download page, there something i have missed. I am a Dumbass, how could I be so stupid.
What? there’s a USB image.

After waiting another hour for the image, I proceed to reimage the flash drive with the usb image.
DD the Image
sudo dd bs=4M if=OI-hipster-gui-20161030.usb of=/dev/sdc
43f76ef68f142a30461fadc76e9155d74aed6b36

This time it boots. :wink:

*********** Disclaimer Setup is Done in VM as I can’t capture a VGA signal *****************


    _______________________________VM Section _________________________________

The Boot Menu

Select Keyboard Layout

Select Language

If all goes well you should see this display, with all the icons, if not sometimes a reboot is required.

Lets Start the Install,

Select the Drive, my is to small for ZFS :frowning:

Select the Time Zone


Select your Language

Add a User and set root password

Summary

Now we Wait.


Let us Pray it works.
In my case it booted.

    _______________________________End VM Section _________________________________
       ____________________________ Real Hardware _____________________________

So what can we do?
Well… IDK at this point still a noob

Lets get screenfeach
wget https://raw.githubusercontent.com/KittyKatt/screenFetch/master/screenfetch-dev

Make it exacutable
chmod +x screenfetch-dev

Run it
./screenfetch-dev

Ok that worked :slight_smile:

Now how do you update this system?
Well OpenIndiana uses PKG to magage the packages.

update the system is sudo pkg update
this may take awhile.

Found some basic functions
Search for Packages
sudo pkg seach -p [package name]

To Install
sudo pkg install [package name]

Still Working though other things, but YouTube works.[spoiler] but the Porn doesn’t LOL [/spoiler]