Home / PC Gaming / Hardware / Store / Discord

ES processor and Rampage V Extreme strange BIOS problem


#1

Hi All,
I just lent a friends Intel Xeon E5 2620 V4 (Engineering Sample), It is compatible with the Intel Xeon E5 2620 V4 non ES version is compatible with the Asus Rampage V Extreme although to actually POST I have to reset the BIOS even If I haven’t changed anything within the BIOS.

I get the Q-Code’s 19 or 53 otherwise.

If I reset the BIOS everytime I boot it works perfectly. It is also the latest BIOS version 3501.

Any ideas what I can do to remedy this?

Thanks,
Jamie


#2

I’m not going to do a whole spiel on ES processors, but with ES processors you get what you got, an engineering sample. They can be quite quirky.

Looking at the manual online, it’s saying Q-Code 53 is a memory error, “invalid memory type or incompatible memory speed”. What memory are you using? Have you tried using just one stick at a time, in different slots?

Don’t forget to take out and unplug everything that’s not being tested. Oh, and resetting CMOS never hurts.


#3

That’s the thing the memory is fine or it wouldn’t boot into Windows after I reset the BIOS and is stable. Yeah I’ve tied that, I’ve also tried some other memory.

I have Corsair Dominator Platinum 2 * 8gb @ 3000MHz, bare in mind that I have not set any settings in the BIOS as it’s default meaning that the RAM won’t actually be running at 3000MHz but instead I believe it’s 2133MHz.

With this information I don’t see how it could be the memory.

Also if Windows goes into sleep mode, it will not wake (well the monitor won’t anyway, the keyboard lights up when it has been woken up), not sure if this has anything to do with the problem but worth a shot putting it out there. I just changed the power settings anyway so that’s not really an issue for me.


#4

All im saying is im not going to go on about an es but u have to be very picky with boards u choose I use asrock as all there x99 run es’s Also most of asus boards work but the gamer boards im less convinced if u can send that asus board back just buy an asrock itll do u a solid


#5

I’ve seen people use my board with ES chips before…


#6

Its an es its not garunteed to work it could also be a faulty es