Can't Boot Windows 10 SSD

Don’t remember what I was doing before this happened maybe updating Windows as I use Windows Insider but anyway my original problem was my pc would get signal of a black screen then turn off after a few seconds tried to repair with windows 10 installer, sfc /scannow, repairing filesystem, rebuilding efi partition and etc to no avail. I gave up and ran off a hard drive since March and now I’m finally once and for all trying to fix it. So tried to rebuild EFI partition again and I deleted the efi partition then mistakenly deleted the boot folder in C:\Windows. So i copied the boot folder from my good install I had been using and rebuit the EFI partition. Now back to the original issue so I don’t know if I fixed the boot drive back to original or if it is messed up from deleting boot folder. This is not a hardware issues I can access all the files using another drive with Windows and Linux although on Linux I get a reading error when I open C:\Windows which I have been getting since the original issue and doesn’t happen on my Temp Windows drive. Also my windows installer doesn’t show any options to enter safe mode or reset pc. I require help and appreciate what you can give thanks.

Specs:

MSI X370 Gaming Pro Carbon

Ryzen 7 1700x at 3.8Ghz

XFX RX 5700 XT Thicc III Ultra

T-Force Dark Za 2x16gb at 3466Mhz

Antec HCG-900

Crucial P1 500GB 3D NAND NVMe PCIe M.2 SSD - Down Boot Drive

Wester Digital Black HDD 4TB x2

Inland Professional 500GB Sata SSD

Random Seagate 500gb HDD - Temp Windows Drive